Linux 下搭建 Qt 环境

很多时候由于跨平台的需要,我们要在各个平台上安装 Qt 并进行应用程序的开发,而环境的搭建尤为重要,因为这是程序开发的前提,属于非常关键的一环。

由于 Linux  各个发行版的安装大同小异,所以下面就以 Ubuntu 为例,详细介绍下 Linux 下 Qt 的环境搭建,具体如下:

  • Ubuntu 18.04 LTS

  • Qt 5.13

1

准备环境

在正式安装 Qt 之前,需要先做一些准备工作,这些都将是软件开发的前提,像 GNU gcc 编译器、make、以及其他开发包的安装。除此之外,要构建图形化 Qt 应用程序,还需要安装 OpenGL 库和头文件。

在 Ubuntu 和其他基于 Debian 的 Linux 系统上,可以通过安装 libgl1-mesa-dev 和 build-essential 包来获得 OpenGL 和最小的开发工具集,即运行以下命令:

$ sudo apt-get install build-essential libgl1-mesa-dev

通常情况下,我们还需要安装 gdb 调试器,甚至是一些其他的可选工具(如 git、clang 等)。当然了,如果需要的话,可以在安装完 Qt 之后的任何时候再安装它们。

2

下载 Qt

Qt 的版本众多,每个版本提供的功能也不尽相同,所以在正式下载之前,应尽量了解一下各版本之间的一些差异(不需要很详细,至少大的差异要知道)。

进入 Qt 下载页面(见:http://download.qt.io/archive/qt/),选择一个合适的版本,以 5.13 为例,点击进入:

一般情况下,这里面会包含几个小版本,选择其中的一个,以 5.13.2 为例,点击进入:

这里面包含了各个平台(Windows/Linux/Mac OS)的安装程序,对于 Linux 而言,下载以 .run 结尾的文件就可以了:

可以看到,Linux 下的 Qt 安装程序只有 64 位的,所以如果你想要 32 位的,那就得去找其他的 Qt 版本了。

还要注意一点,具体安装 32 位还是 64 位,最终取决于系统的体系结构。如果不确定是何种体系结构,可以运行 arch 命令并检查输出:

$ arch
x86_64

倘若输出“i686”则表示 32 位,而“x86_64”则表示 64 位。

3

安装 Qt

在下载完 Qt 之后,需要先为安装程序赋予可执行权限:

$ chmod +x qt-opensource-linux-x64-5.13.2.run 

现在便可以运行安装程序了,你有两个选择:

  • 以普通用户身份运行:将被安装在当前用户的主目录中(默认位置:/home/waleon/Qt5.13.2),从而使该安装只适合安装它的用户使用。

  • 以 root 用户身份运行安装程序(使用 sudo 命令):将在全局范围内安装(默认位置:/opt/Qt5.13.2),并且可供系统中的所有用户使用。

确定好这一点之后,运行安装程序:

$ sudo ./qt-opensource-linux-x64-5.13.2.run 

这时就会启动安装界面,直接傻瓜式安装(下一步、下一步)就行了,这里重点说一下都需要安装哪些组件:

这些组件分为两部分:一部分位于“Qt 5.13.2”下,主要包含了 Qt 的开发库以及源码;另一部分位于“Developer and Designer Tools”下,主要包含了 IDE(Qt Creator)以及其它一些工具,有助于我们提升开发效率。

组件说明
Desktop gcc 64-bit使用桌面版 GCC 64-bit 编译环境生成的 Qt 库,是 Qt 的核心,必须安装。
Android*针对安卓开发的 Qt 库,如果有这方面需求,可以自己选择安装。
SourcesQt 源码,除非想研究源码,否则不用安装。
Qt*

一些附加模块,大部分建议安装(占用空间不大)。其中,模块后括号里的 Technology Preview 表示技术预览,说明该模块仍在开发中(非正式版模块);而 Deprecated 是指被遗弃的旧模块(兼容旧代码使用的),一般用不到。挑几个组件介绍一下:

  • Qt Charts:2D 图表模块,用于绘制柱状图、饼图、曲线图等常用图表。

  • Qt Data Visualization:3D 可视化模块,用于显示条形图、散点图、曲面图以及操纵 3D 场景。

  • Qt Lottie Animation (Technology Preview):动画模块(适用于 QML),用于渲染 Bodymovin 插件以 JSON 格式导出的图形和动画。

  • ......

  • Qt Script (Deprecated) :脚本模块,已经被遗弃了,不建议使用。

Qt Creator 4.10.1IDE,后续就靠它写代码了,这是强制安装的。

当点击左侧的组件时,右侧就会出现对应的详细说明,不妨看一看!

4

设置环境变量

想让 Qt 更好地为我们服务,就需要扩展一些环境变量。像 qmake、moc 以及其他的一些 Qt 工具所在的路径,都需要加到 PATH 里面。

具体的做法,打开 /etc/profile(对所有用户有效):

$ sudo vim /etc/profile

在该文件的最底下添加以下内容:

export PATH="/opt/Qt5.13.2/Tools/QtCreator/bin:$PATH"
export PATH="/opt/Qt5.13.2/5.13.2/gcc_64/bin:$PATH"

注意:/opt/Qt5.13.2 是 Qt 的安装路径,这里需要修改为自己对应的路径。

在保存退出之后,执行以下命令即可修改环境变量:

$ source /etc/profile

测试一下,看是否设置成功:

$ qmake -v
QMake version 3.1
Using Qt version 5.13.2 in /opt/Qt5.13.2/5.13.2/gcc_64/lib

没问题,版本信息正常输出了。

5

基本测试

还有一点很重要,就是检查构建套件是否设置正常(默认会自动配置),包括编译器、Qt 版本、以及调试器(如果存在):

在确认无误之后,建议创建一个示例项目来测试一下:

O(∩_∩)O哈哈~,棒棒哒,程序完美运行!

更多参考:

  • Qt for Linux/X11:https://doc.qt.io/qt-5/linux.html

  • Install Qt 5 on Ubuntu:https://wiki.qt.io/Install_Qt_5_on_Ubuntu

·END·
 

高效程序员

谈天 · 说地 · 侃代码 · 开车

长按识别二维码,解锁更多精彩内容

展开阅读全文
©️2020 CSDN 皮肤主题: 技术黑板 设计师: CSDN官方博客 返回首页
实付0元
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值